HA-Bridge addition


#1

I realize there is another way to get Alexa to work with HG but being new to HomeGenie it looks like a difficult process to setup, from what I read.
Also it seems unlike HA-Bridge it doesn’t add anything other then Voice control.
I’ve only been using HA-Bridge for a year or two and HG a month or two but I’ve managed to get the two working well together.
With the addition of Broadink RM support added to HA-Bridge I set about looking for away to have HG use possible devices.
I was about to code a new program for HA-Bridge when I notice the code for talking to a Philips Hue bridge was very simular.
I don’t have a Philips hue Hub so messing up the hue program by modifying the existing code wasn’t a issue for me.
I’m surprised no one noticed the similarities prior(or maybe they did and I missed it while going through old threads).
In any case here is the program for anyone interested 26-HA-Bridge.hgx (6.2 KB)


HomeGenie for Dummies Document - X10 Centric
X10 Security devices, HG, HA-Bridge, & RM Broadlink
#2

I updated the Bridge HG program with Password protection as HA-Bridge could be dangerous if accessed by the wrong person.
the user and password need to be configured in HA-Bridge from the “Bridge Control / Update Security Settings” page in order to secure HA-Bridge.
I hope others find this as useful for them as it is for me!


#3

HA-Bridge
Notice this displays HA-Bridge 3 this is the third item in my HA-Bridge device list.
Configuration of this is very simple.
Username can be any thing you like however if you use security in HA-Bridge it must match that.


the rest of the settings I believe are self explanatory.

Note: Things added in HA-Bridge become visible to Amazon Alexa devices so if your using other Alexa control in HG you may have to rename things to avoid conflicts


#4

Thanks. I think I am downloading the HA software from your last post. thanks again. I will continue discussion in the x10 thread


#5

I can’t wait to plug in my Broadlink RM later this morning and see what happens!

I assume I will find out what your 26-ha-bridge.hgx is then also - looks like something that loads into the RM…


#6

This will allow control of any device setup in the HA-Bridge software. This nor the HA-Bridge its self writes to the Broadlink RM.
Since you have a Broadlink now you need a way to have it discover IR and RF I used the android app RM Bridge (can be found in the app store or link below) once you set that up you go to http://rm-bridge.fun2code.de from there you can manage codes learn/test/import/export.


#7

this keeps getting deeper and deeper! haha! now I need a cell phone app to teach the RM to be smart. Hey, if i get this working, I definitely will documenting it as there is no way in heck a single person could figure all this out! Oops… you did. :slight_smile: You should change your tuicemen to t-wizard.


#8

LOL there is a windows application that can be used to learn codes as well there are several others in GitHub. The Phone app Is the first one I tried.
Apparently if you load the Econtrol app for the Broadlink you can get the codes from it by searching in your phone after the codes are learned from it but it sounds like a bit more work.


#9

i have rm thing plugged into power. it is flashing lite 3x/sec as instruc sheet says.

I feel totally blind here. I installed your recommended rm-bride on my phone. It says not connected, I click it and it says connected. Nothing happens. wft?

so I download something rm recommends in manual named e-control (Ihc?) wtf is its sign in? where? to what? I go thru some sign in to who knows where thing and it asks me to add device by bar code! ok, past that. now it lists various things made by broadlink. wtf? no clue what this is about.

meanwhile, rm bridge is still happily started on my android phone but does nothing.

I may be too old to figure this new fnagled stuff out. I give up for today.


#10

and so far I have no windows programs called HA-bridge. I am at a real loss here.


#11

i do have habridge jar, can click on open but nothing happens. of course 127.0.0.1 is in use with HG! But where to set a different port for this invisible thing?


#12

HA-Bridge.jar is the program.
you should have it in a separate folder. when you click on it HA-Bridge loads a web interface just like HG. be default it wants to load to port 80 since you most likely have HG loaded to that it will fail.
the easiest way to fix this is to change the port for HG to 8080.
restart windows then click on the HA-Bridge.Jar file you may get a windows firewall pop up asking for java permission to run you should click yes.
when HA-Bridge runs the first time it will create a data subfolder that holds a bridge configuration and data file.
to open the HA-Bridge go to 127.0.0.1:80 if you wish HA-Bridge to start when windows starts you have to add a short cut to the Jar file into the start up folder.


#13

so I found this .jar is a zip file so I unzipped all 6000+ files into it’s own directory, no .jar file left to run so nothing to run. learning that .jar is a zip of files/folders that java uses as is… ok, I will go delete my unzipped file.

So I am beginning to think I do not have jjava installed on any of my win 10 machines… so trying to install as it seems needed. finding that windows edge browser does not support it. tried installing in Firefox and it reports that newer Firefox browsers may not work with java. down to chrome browser… it seems to be accepting it so downloading a huge file to install.

see? instructions are needed! everyone else trying this the first time will have to go thru all these same learning curves and learn about java and stuff. THIS INFO should be in FIRST LINE of ha bridge docs! sheesh.


#14

You don’t in zip the ha-Bridge.jar file!
Be sure you have java 8 installed
Make a directory and place the Jar file into it then run the file. you will not see anything until you open your browser to localhost or 127.0.0.1. However if HG is still on port 80 you need to change it or HA-Bridge will not run.
It has been a while since I initially configured the Broadlink but I do remember running Econtrol. That is required initially so the broadlink can access your router as it is Wi-Fi.


#15

so ran econtrol and got RM on wifi. tried to teach it A16 to turn fan on or off and although it said it learned it, nothing happens. not sure how it would do it without a connection to cm15…

Today I find all my security modules blank and HG does not show receiving any sigs from security things. still shows and works regular house codes. Not sure what broke the security stuff… x10 virtual RF is still on, .had a reboot or two, installed java, tried to install/turn-on Habridge, ran Econtrol and have this rm thing here with no lite on anymore…

Guess I will have to begin working backwards, uninstalling each item until I find what made security no longer work…


#16

the RM learn states a name isn’t required however I found it is.
I named codes to what they did eg: A1 on, TV On…
in my forum in the broadlink section there is are a few Broadlink X10 codes that you import.


#17

thanks. I appear to be going backwards fast today. none of my remotes (hr12) work, none of my security arm/disarms (kr10, sh624) work, even my V572 does not see any of them and it is 10’ away! My DS7000 will not arm or disarm with RF; it arms with local ARM button but then I need to remove batts and ps to reset it…

only thing that DOES show rf received is V572 if I send ARM or disarm from ahp thru cm15! It flashes so it is seeing it, but ds7000, 10’ away, does not see it.

talk about frustrating!

OF FOR CRYIN OUT LOUD!!!

this dang RM thing must have been sitting here transmitting 300mhz crap non stop!!! I unplugged it and got my RF controls back.

back to the drawing board again!


#18

The broadlink should have been constantly blinking if it was sending continuously. At least you found the issue. you may need to do a few tests with it as it may be defective.


#19

I doubt it is defective - I am good at finding bugs and making stuff work the way it is not supposed to. :slight_smile:

Now to figure why HG tossed all my learned DS10 switches and keyfobs!


#20

hope you made a configuration back up.
If not you’ll want to do that once you get every thing back.