X10 Security devices, HG, HA-Bridge, & RM Broadlink


#1

I need to thank Tuicemen, Kevininv, and Peted for all their help that got me this far.

A couple of basic things I learned:

  1. AHP & HG coexist nicely on the same computer as long as you use 2 different USB ports. Switch back and forth only takes about 4 sec for the computer to move the cm15 to the other port.

  2. X10 security modules, including keyfobs, work but there appears to be a HG bug: On reboot, first time running HG again, all the security modules show up as ‘undefined.’ They populate the names back and work again after the security code is sent and seen again.

  3. New installs of windows 10 does not include java - it must be added for HA-bridge to work

  4. HA-bridge’s default port 80 can be a killer to getting it to run. Even after changing HG to another port, something else still is holding port 80 on my computer: I solved this by running HA-bridge across my network from another computer and changing HA-bridges port from 80 there. Now HA-bridge works on my HG computer. My IP scanner shows something running probably hogging port 80, called Microsot IIS httpd 10.0

I am continuing to add this type of info to a doc I will share soon and merge with Kevins great doc.


#2

The HA-Bridge port can be changed from inside the habridge.config file found in the data folder of the HA-Bridge folder. this may be confusing to a newbie as I’m not sure if the file is created on first run if HA-Bridge fails OR only on a successful first start.
In any case you open the file with a text editor like notepad in Windows.
Look for the entry “serverport”:80, and change the 80 to the port number you wish then save the file.

Now starting HA-Bridge the address you put in the browser needs to end with “:Newport#” no quotes


#3

Thanks. NOw that I have habridge display in browser I can go back and read what to do with it!


#4

HA-Bridge was created to allow interfacing different HA protocols with Amazon Alexa and I believe this is still the Authors main Goal.


#5

Boy I have a lot more learning to do! So far I have not dug into what HAbridge can do for me, but was able to get my cell phone to communicate with the broadlink RM pro. I was able to teach it a couple simple A5, A16 codes that it now repeats from my cell phone screen. It does not seem capable yet of learning the RF via scanning to capture my KR10 keyfob since it is a single short shot RF send, but it does seem satisfied capturing the SH624 security remote. But the SH624 emulator sends a short burst of about 5 msec, as opposed to 500msec burst of yellow RM lite for the A5 or A16 sends, that does not arm or disarm my DS7000.

I have no understanding yet of how this RM thing talks to my wifi network; I do have a 192.168.0.12 device showing up in my wifi list on my computer as the RM thing, but I have no idea what to do with it yet…


#6

The Broadlink has a very short range for learning signals.
For learning the Security codes from a key fob be sure it has new batteries to deliver a strong signal. Also once you start the learn process repeatedly press the key fob button as many times as you can while the Broadlink is in learning mode.
One thing I discovered is you’ll want to set up static IPs in your router for the Broadlink otherwise HA-Bridge can’t talk to it if your router assigns a new IP.
It is a good Idea to assign static IPs for all your devices as it makes for faster connections as well.
When using your Phone and the broadlink app your using the cloud.
If your using the rm-bridge on your phone it sends the signal to the Broadlink via wi-fi the same as the HA-Bridge will. My understanding is the Broadlink doesn’t store any thing it just sends out the code it receives.


#7

Man you are a pillar of wisdom!!! THank you! I learn every time you post!

I do static IPs here - learned to stop relying on the DCHP years ago.

guess I just need to press and press and press longer on my keyfob! it is 3" away from the RM so no issue there.

I think the SH624 issue may be its old antiquated 24 bit send instead of 32 bit I have seen reference too. Although my DS7000 likes it, the rm does not yet seem to be able to emulate it properly.

I have the rm bridge on phone, it is STARTED, but I assume until I learn to make Ha-bridge talk to it it will continue to do nothing… Like you say take it a step at a time… I will retry my keyfob teaching to RM as next step.

THANK YOU!!


#8

tUICEMEN, where do I send you a paypal case of beer???

I held keyfob 1" from RM and it registered! I can now ARM/DISARM from RM thing on phone!!

I could kiss you!!!

Now to integrate Ha-bridge between HG and RM. That is for tomorrow. :slight_smile:


#9

the RM Bridge that you have running on your phone should be used to learn codes if your wishing to use HA-Bridge.
Since you now have the Brodlink working with its App it is time for the next step.
1: Run RM Bridge on your phone
2:now with the broadlink next to a PC go to http://rm-bridge.fun2code.de/rm_manage/
3: select Create new codes
4: in the new window just follow the steps.
5: when you get to step 3 include a name for the device even though it says it is optional before you press the learn code button.
6: This saves the code to your phone for future use with HA-Bridge

To access all codes learned this way
1: go back to http://rm-bridge.fun2code.de/rm_manage/
2: click on Manage code shortcuts
3: if the address to the app doesn’t display type it in then click load codes

Once you have the codes loading this way and working from here I’ll explain how to add to the HA-Bridge.


#10

For paypal there is a link on my forum all proceeds go to keeping my forum alive.
http://forums.tuicemen.net/index.php?topic=1185.0
Currently I have a new WM100 which I plan to draw for from those that donate this year by end of August.


#11

Thats just wrong and the sort of problem we have with people at work… dont use IP addresses… DNS was invented for a reason - use a hostname -assuming dhcp updates dns if you env is configured correctly…

Or use DHCP and configure a reservation so that mac address keeps that IP - then you dont have to worry about statically assigning IP’s… DHCP is the way forward :slight_smile: - but whatever works for you!


#12

Sadly not all routers are configurable the same way.
I stated set a static IP as that is what my router calls a reservation.
I’ve not disabled DHCP but do have some things set with a static IP or reservation.


#13

I agree. DHCP is a good thing and of course we have it on too. But there are good reasons to set static IPs on some devices.


#14

1: Run RM Bridge on your phone

  • easy, done
    2:now with the broadlink next to a PC go to http://rm-bridge.fun2code.de/rm_manage/
  • easy, done
    3: select Create new codes
  • easy, done
    4: in the new window just follow the steps.
  • haha! can’t get past step 1! first it shows an IP address of my repeater router; no connect. then I killed the bridge app and restarted and it showed the IP address of my phone - sounded probably right, but no connection, killed it and started again, this time it shows some internet address, not even my modem’s connection to my IP… now I need to check ICANN for who this 100.84.88.165:7474 address is…hmmm… for use by internet provider only… oh well I will click it… nogo… tried my broadlink’s address… nope…

I don’t know who’s address it wants? my phone? my router? the broadlink rm? I will try broadlink MAC address entry next… NOPE. dada…

I cannot get past step 1 (:slight_smile:

5: when you get to step 3 include a name for the device even though it says it is optional before you press the learn code button.
6: This saves the code to your phone for future use with HA-Bridge

1: go back to http://rm-bridge.fun2code.de/rm_manage/
2: click on Manage code shortcuts
3: if the address to the app doesn’t display type it in then click load codes
[/quote]


#15

Step one should be the IP of your phone and the port number the rm bridge is running on. Make sure your phone is connected via wi-fi 2 ghz to your router and not using a data connection. the 7474 port I think is the defalt port the rm bridge app uses used the ip and port the app displays
Did you try a manual add? I’ve never had to do this.


#16

Thanks for the phone IP info. I cycled power on the RM thing, and now RMbridge came back with the phone IP address and it connected I guess

step 2 device picked is all chinese charaters so I assume that is ok

5: when you get to step 3 include a name for the device even though it says it is optional before you press the learn code button.
6: This saves the code to your phone for future use with HA-Bridge

STUCK here now: It does not complain on step 1 so assume it connected. Step 2 is chinese gibberish
image

this DOES show the my RM things MAC address.
step 3 named A16 but states “set freq scan failed” and I am not getting around it…

1: go back to http://rm-bridge.fun2code.de/rm_manage/
2: click on Manage code shortcuts
3: if the address to the app doesn’t display type it in then click load codes


#17

I think my issue may be that damn DHCP… It set my phone to 192.168.0.2, and I believe that is my house wifi repeater address… DHCP is not a clean process by any means!

I just tried again with my phone touching the RM thing and my remote also touching it. It took the freq scan, and it took the code, and the code works in the test box on the german site. I will add a few more lamp/applicance modules and try to add my keyfob. This all worked just like it did not e-control when I got them to learn, but they all dissappeared as I keep hitting the reset button on the RM. I will not reset anymore as it seems to work.

so back to last step. guess I am ready to go on to ha-bridge?


#18

aha! I found your forum write up step by step “Adding RM Bridge codes to HA-Bridge”

Going for it now…


#19

the forum write up I believe was for before the Broadlink support was added I believe.
ok sounds like your ready to go to the HA-Bridge but there is some prep work open a new text fie in note book. go to http://rm-bridge.fun2code.de/rm_manage/export_codes.html and select export codes this will display all codes you have learned with this web interface.
each device will start with “data”:" copy all the info from that to the next comma don’t include the comma.
paste that hex string in the note book file and add the device it controls afterwards so you know what code belongs to what with that file created you now have a handy reference.

1: Open the HA bridge web page and click on bridge control
2: scroll down till you see broadlink control check the box next to it the scroll back up and press save
3: once HA-Bridge reloads go to the bridge control tab once open you should now have a tab next to logs which says Broadlink devices click on that tab.
4: give it a few seconds to load and your broadlink device should appear if not press refresh.
5: with your broadlink displaying scroll over to the on actions from your txt file copy the hex value to this box do the same for the off
6: make sure the broadlink device is checked then click on build item. this will open the add edit window
7:in the name box will display broadlink rm so something simular type in the name for the device and click add device.
8: this takes you to the device list so you can test the on and off codes
9: only do the security codes first as that is what is important to you for now.
once you have that working will move to adding it to HG which you may already know how but if not let me know.


#20

thanks for the update! I just got to adding some from rm bridge and notices they are all useless! That dang DCHP again bites us! mY phone already switched from one router to the next extender here and the IP address changed again. So ALL These codes generated by rm-bridge as useless. Hope your new scheme gets around the musical chairs of IP address due to DHCP… Thanks.