Homegenie with Bullseye?

Can Homegenie be installed on Raspberry Pi Bullseye operating system? Don’t get me wrong, I am a great fan of Pi with buster running HG. and am thankful for the re-purposing of old X10 modules. Can X10 survive into yet another decade? If not I will just keep going until everything fails and they bury me with my old LG cellphone in hand. Thanks for any guidance provided.


HG hasn’t been updated in a long time and Bullseye is more recent. It’s possible it will at least partially work but the only way to know would be testing. From past OS updates, my inclination would be HG will require an update to the installer but maybe this will be a first time that won’t be required.

Ironically there was an issue with the HG installer back when Buster replaced Stretch as can be seen from this post Anyone upgraded to Buster with HG? - #10 by Petediscrete

The most likely problem usually stems from package dependencies issues which can be resolved by manually installing HG and all its associated packages. Not ideal but it can be done.

The bigger question will be backward compatibility issues between board models. There’s no doubt that Raspbian Bullseye is targeted at Gen 4 board architecture but still has backward compatibility built in to a certain extent. Of course there is a shift on emphasis from the SD card installation to an SSD or USB equivalent on the RPI 4

Finally with the RPI 4 you’re not restricted to Raspbian. Something to bear in mind.

As @bkenobi suggested the best way to answer your question is to try an installation yourself. Install Raspbian Bullseye first and once you run the HG installer your question will be answered quite quickly.

The bigger question is will X10 outlive HG. Now there’s a question to ponder :thinking:

Thanks to you both for the speedy replies.

I tried installing to the new pi release, but got a whole bunch of error messages, so I will wait until I either update the pi (not likely, I like the pi 3B+) or find another control system that will handle X10 this well. X10 is all I have and I can’t see that changing as I still have a box full of various modules, some of them 40 years old.

In the meantime, thanks for all your assistance with this remarkable app and in resurrecting this system.


Admittedly I have not been looking recently for a different HA software as HG has sat quietly running on my RPi3 without issues for a long time. The SD failed so I dropped a backup in and away we went.

That said, before picking HG I looked at all of the available options that could use X10 and could be run on a SBC. There are other options available that will work with X10 and technically are just as capable, however they are a bit of a hack to make everything work. Last I checked, home assistant could run both PLC and RF X10 however while PLC was natively supported the RF required a wonky work around that I didn’t like. It would work if you needed to use HA. I believe Domoticz would have worked too, but I haven’t checked them in a while. In either case, they utilize mochad to integrate X10 which is robust and works well however is not fully integrated like HG. IMO, HG has the best X10 support and until it stops meeting my needs, I’ll probably continue using it.

If others have a different perspective or more thorough/current knowledge on other fully integrated X10 options I might be swayed to look again. :wink:

I have checked into Home Assistant and will probably do a trial run on a micro card just to get a feel for it. As for strange applications, I don’t think it could be much worse than some of the apps that have tried (and failed) to impress me before I stumbled onto HomeGenie. I will give them a try but will likely be back. Thank you again for the guidance you have given me.


Home Assistant is not too X10 friendly so it would take quite a bit of work to get it right.

As you mention you’re using HG purely for X10 and in fairness it’s probably the best “free” application for X10.

I smiled when you said you got a bunch of errors trying to install HG on Bullseye. It’s that bunch of errors we need to know so we can help you proceed.

As soon as I get time over the next day or two I’ll give it a whirl on a 3B + and see what comes back from it. I’m the meantime try it again and try copy paste those bunch of errors here so we know what we are looking at. It might be something simple that can simply resolved

OK. Got a moment and gave it a whirl. The good news is it’s working fine.The bad news is…well there’s none really. This was done on a Pi3B+, Bullseye and using a CM15. I installed from the point of downloading the image, unzipping it,used Win Disk Imager to write the image and followed the install instructions from here below

sudo apt install gnupg ca-certificates

sudo apt install apt-transport-https dirmngr gnupg ca-certificates
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/debian stable-raspbianbuster main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update

wget https://github.com/genielabs/HomeGenie/releases/download/v1.3-stable.19/homegenie_1.3-stable.19_all.deb
sudo apt-get update
sudo apt-get install gdebi-core
sudo gdebi homegenie_1.3-stable.19_all.deb

If you follow these instructions you'll be up and running in under an hour. Just back up your current HG and you can restore to the new install. That's me done.

Note. Use the Bullseye Lite version NOT the Desktop.

Amazing it worked pretty much out of the box. That’s a pleasant surprise!

For anyone using X10 it certainly was a pleasant surprise. I can’t comment on other technologies that HG supports as it really was just a rushed installation to test if HG would install on top of Bullseye and if X10 would function correctly as per the OP’s original post.

Maybe others could look at migrating their HG setup to Bullseye and test it a little further. Do bear in mind Bullseye has been dogged with problems since it’s released and as a result the authors have released a legacy version of the new OS to address some of those issues. You can read all about this here.

I’ve been running HG on Bullseye (full) since it was in put in beta testing. I used the install method @Petediscrete mentioned.
FYI I also install it onto the new 64 bit Raspberry Bullseye OS (lite) on a Zero W2 with no issues the same way.

Indeed but the OS version of Bullseye in release bears no resemblance to the beta version as can be seen from the link above. It’s a legacy version and my advice to users would be to avoid Bullseye for anything but testing for as long as they can until the actual version they intended to release becomes stable and freely available. In other words…no hurry to upgrade.

I purely provided these instructions gathered together freely available from other sources to ally the fears of the OP that X10 may not be usable with HG into the future and can confirm as it stand now it certainly is.

There’s so many platforms available these days that HG can be installed on it would take an age to list them. Most are flavours of SBCs/Linux variants and of course good old MS Windows. The main thing here is the platform the OP enquired about will successfully install/run HG in an X10 scenario.

In the link you provide it was stated that once issues with Bullseye were sorted out a 64 bit version was next. Since the 64 bit version was release Feb 2, it would suggest the issues were resolved. Unless I miss read the article.

I was responding to the OP’s desire to get X10 working in HG on Raspbian Bullseye using an RPI3+. Mission accomplished as confirmed by myself and confirmed by @bkenobi . I didn’t even consider using an RPI4 for test purposes purely as it would be overkill in this instance.

Rather than clutter this post up why don’t you start a new post with all your findings and all the different variations of install you managed with HG. In the meantime for anyone interested in the progress of Bullseye and the difficulties encountered with it you might want to take a read of this. https://www.google.ie/amp/s/www.hackster.io/news/raspberry-pi-launches-legacy-operating-system-for-those-finding-the-shift-to-bullseye-a-challenge-dbb9f9c4f40d.amp

I never suggested testing with a raspi 4 or installing a different OS. I merely stated I tested the 64 bit version of bullseye which according to both your links wouldn’t be released untill issues with Bullseye (32bit) were resolved.

The 64 bit Raspberry Bullseye OS works with the 3b+ and newer pi boards not just the pi 4

@oldcanuck just to confirm I installed the following version of Raspberry Pi OS when running my tests

Raspberry Pi OS Lite

  • Release date: January 28th 2022
  • System: 32-bit
  • Kernel version: 5.10
  • Debian version: 11 (bullseye)
  • Size: 482MB

The version can be downloaded from this link. Just wanted to clarify this so as to avoid any confusion

Thank you all for your input. I will be testing this out in the next few days (when the wife is at work, I don’t want to offend her with the language used to tune the RPI) I will be checking and reporting back in with news on my progress. I still am a newbie at all this and appreciate the guidance.


I’m assuming you have no issues setting up the RPI3b+ from scratch. Once you’ve created the image onto the SD card don’t forget the step to enable SSH.

I’d highly recommend shutting down your RPi gracefully with your current working setup and moving that card to a safe location. Then with your shiny new SD that you are working on, you can curse away without potential catastrophe! Forgetting what is on a generic looking card can cause a lot of heartburn. :roll_eyes:

Yes I’ve been there too. Can’t write on a micro SD card cover. The regular SD cards on the Pi 1 were a little easier to mark.