HomeGenie for Dummies Document - X10 Centric


#41

Sure- you can add an appendix or just integrate with mine if you think that makes sense… My doc is “open source” so anyone can update it as they see fit :slight_smile: Just repost it anytime! :slight_smile:


#42

Bkenobi says he never played with the security in HG.
I do see a use for the IR controler other then for security. Maybe today I’ll get somewhere can you upload a sample of this working for your smokedetector it may help me better understand how this works.


#43

You keep referring to IR so are we talking IR or RF. The instructions I gave you cover both. Once you have installed the x10RF package via the MIG installed the method I outlined above works.

Have you managed to capture an RF code on the widget you created. I assume you have a KR22E or such like that you can use to test the transmission and capture of RF hex codes.

I have an old ATI Remote Wonder RF remote control which HG will gladly capture all the RF hex codes that you issue.

After that I already explained the method of creating a widget, assigning it as a switch, binding it to IR Remote Controller, Enable control by IR remote tick box and using the little :eye: to record the RF command and saving it.

If your sensor/remote issues valid RF signals 319/433mhz than HomeGenie will accept it.


#44

Wonder if there is anything that can be done using the ahcmd.exe command in commons folder?

ahcmd [sendsecurerf/sendsecurehomecontrolrf] [RFcommnad] [security type] [security code] [transmit] [delay]

I’ve gotten some of them figured out but am still working on the rest.

sendsecurerf = [arm away]
sendsecurehomecontrolrf = [arm home]
security type = [standard or extended][why/what ?]
security code = [house code]
transmit = [?]
delay = [?]

above from wmikef7 on x10 forum in 2009…


#45

I am not sure what you are trying to say here? I have modules for each of my DS10 security devices and HG certainly sees them turn on and off. All from help here! From this it seems to me HG does recognize the security proprietary codes.

I apologize for apparently asking too many questions. I thought this was a give and take forum to share ideas and offer help when possible; why I was beginning a doc to add to Kevin’s with the missing descriptions of HG use. If you think I am asking too many questions and this is your forum I certainly will go away and stop bothering you. Just tell me.


#46

Not at all, but your comment …and your point is…was a little condescending.

I thought I’d already made the point that x10 security sensors were highly unlikely to work in HomeGenie. If someone does manage to provide a workaround, all the better. Personally I don’t use them.

I outlined the method of getting RF working in HomeGenie which I thought was quite straightforward.

You have to realise that the X10 user base would be quite small here. Users have moved on to more modern and reliable technologies.

Maybe if you take your query step by step wait for a response and report back success or failure on the suggested solution it might make it easier for others on here to help you.

Don’t forget this is not a commercial product and support is purely offered on a goodwill basis by some very helpful and knowledgeable users and we do have time zone differences to deal with too.


#47

@mike the ahcmd.exe uses the AHP cm15 driver itwill not work from HG. The way AHP sends security code is via code in the x10net thats why it states the Cm15a needs to be connected. When I state something doesnt work I’m refuring to HG not AHP.

@Petediscrete I believe the European cm15 is more like the cm14a it had IR capabilities (cm15 beta prototype) There was a patent issue with adding IR to the release build in North America so it was dropped here.
The cm15 you have is a far more superior unit then the CM15A I have. There are a few CM14As arround still but these are mostly in beta testers hands. The fact that you can get somethings to work in HG verses some one using AHP is not only a driver thing but hardware. Your including the IR controler setupthough nice made it confusing to me as it is not needed to see X10 RF. I’ll cotinue to play with it as I like that it will see RF codes that may not normaly be used.


#48

OK on reading my question as condescending - was not my intent. My intent was questioning why you say things like this.

I am not the only one who indeed DOES have x10 security sensors working 100% in HG; so I am still confused why say it is highly unlikely to work? I am just trying to go to the NEXT step of being able to SEND security RF emulating security x10 keyfobs.

Also FYI, many of us have totally 100% solved reliability issues with our x10 security system. My solution was to hardwire all the magnetic door switches and run them thru Cat5 cable pairs back to the location of my DS7000 security panel. Now the RF DS10’s only need to jump 3 feet over to it, making that portion of the security system 100% reliable. In addition, most of us have added external RF receivers like V572RF32 with antenna at 25’ to reliably capture all RF signals in our 1/2 acre compound. Most have also included the powerful XTBR power line repeater to add to reliability.


#49

Yes CM15 Pro being deployed here. TIP10RF looks after any shortfalls of the CM15 Pro over remote connections and is used in other setups I have like Domoticz

As I said earlier, I don’t use x10 security sensors or panel so I couldn’t vouch for their usability. I thought bkenobi had managed to deploy them at one stage but I’m now informed he hasn’t.

At least you’ve got some form of RF working with HG now


#50

That is why I am so confused by your replies. You state as fact that x10 security devices are highly unlikely to work in HG. Then you say you have never tried to make them work. Tuicemen has them reliably working I believe, and I have them reliably working, so I am soooooooo confused by your comments!

I will refrain from asking for help here and presume I will reinvent from scratch what others have already learned and seem willing to share. I am not able yet to get my broadlink RM to do anything or talk to my computer. I am not yet able to get HA-bridge to show its face either, even after successfully changing my HG to port 8316 and finding the only windows 10 64 bit machine browser that says YES to Java is the old Microsoft Internet Explorer - yet it refused to talk to anything but my HG @ 196.168.0.13:8316 so far.


#51

@mike since you have Windows and can switch to AHP and its driver by swapping out the USB do that.
then go to http://tuicemen.com/alex10 download and install Alex10 this should help get ha-bridge up and running on your PC.
if you have issues there are help threads in my forum for Alex10 once you have Alex10 seeing ha-bridge as running you no longer need Alex10 and its exe file can be deleted but not the folder which will contain HA-Bridge, and the data subfolder used.