HG Hangs on startup 75% of the time


#1

I have been using HG for a number of years and have always had this annoying problem.
I am currently running Windows 10. When I start up HG it will hang in various stages of starting up until I either refresh the screen a number of times or stop the HG process and start over.

Sometimes the Genie will just sit on the screen, sometimes the spinning arrow spins for hours and sometimes it works fine.

It happens in all the major browsers and has happened in the past from Win7 to the present Win10.

The problem will also manifest itself when I go back to the “Dashboard” page from any other page available by clicking the “Home” button. Sometimes the screen populates with my information and sometimes not.

It has happened in all the iterations of HG over the years. This problem is not a show stopper for me as I am very happy using HG it is just annoying. Especially when I have to remote into the computer to control a house 150 miles away!!

Thanks for reading this.
Alan


#2

I think every HG user suffers the same problem. Some browsers work better than others but none are perfect with HG. the program probably needs a rewrite.


#3

Thanks for the reply. In a way I am glad I am not the only one.


#4

Yes, I have to admit that this problem exists. I hope it will be solved when we rewrite server API in part of web-server.
Btw, do you host HG on Windows?


#5

I use HG only in a Windows environment. I have to remotely
control a home that is 125 miles away and has satellite internet
service. So my only way of doing so is with a remote program
called LogMeIn and it only runs in Windows.


#6

Running Windows 10 and running LogMeIn through a satellite internet connection. Because a static IP address is not possible I have to remote in with LogMeIn.


#7

Alan,

I had the same problem, locally. My solution was to run HG on a Raspberry Pi. MS Edge, IE, and Google all work well. This may not be reasonable for your application.

I did not see a mention about computer use. Is HG the only running program or are there other uses? I found Firefox to work about the best for HG on W10. Windows 10 does a lot of system loading all by itself. Try shutting off Cortana and the auto update. Be aware that the latest release of W10 only allows a temporary pause of 35 days. See if this helps.

Tom


#8

I am newbie; any solution yet?


#9

Any details about your installation/using patterns?


#10

win 10, 64bit. installed first on win 10 64bit laptop on my network and the dashboard came up fine. I uninstalled it from laptop and installed on my full desktop machine and have never seen a dashboard - just rotating circle (wait symbol) Now and then one of my ADDED groups DOES show up with the X10 switches I have…


#11

Do you have IIS installed on your desktop machine?


#12

no IIS. I got it working again by using Revo uninstaller (so it uninstalled all the registry left over bits too) and reinstalling it fresh. (Plain windows uninstall first try did not fix it). I am back to running again. Thanks.


#13

I have to refresh the screen 3 or 4 times on every program load to get it to start. It is the rare exception for a first time load.
I did read a post about adding the local host name to the start address but either I did not fully understand the post instructions or that failed to work for me also.


#14

I might help you try this… I can load firefox everytime ok, but chrome refuses to open just hangs - when I enter the computer address…

To show you how to enter the computer name instead, I stepped thru it to write it down for you AND IT OPENS FINE IN CHROME NOW THAT WAY! Cool.

Here is how to use computer name instead to open:

  1. click on my PC, click on system properties, write down the computer name, shown as “Device name”
    1a) alternate whay to find computer name: go to control panel, click on system, write down “Computer name”
  2. open browser
  3. type in that name on address line, press enter

That’s it!
My computer name is MK-123H-SSD. First time I did it, it asked me if I wanted to go to http.MK-123H-SSD and I said OK. Came write up.

Now I can just enter MK-123H-SSD and it comes right up.

Hope this helps.


#15

This issue isn’t limited to HG nor does it seem to be a specific browser or Windows itself.
I’ve used several windows server programs to interface with programs I’ve written and have had several users report issues with logging in.
Some PCs have issue with using localhost or the actual PC IP. I suspect it is a hardware issue.
Many times using Mikes suggestion works as does using http://127.0.0.1


#16

HG not loading in chrome again; says at bottom “waiting on available socket” Googled, found this is when a page tries to load too many things at once.

Went to suggested address, saw 75 HGs in list! Hit suggested flush socket pool and HG again is loading!

chrome://net-internals/#sockets

Bookmarked that to my X10 folder


#17

I feel bad keeping this thread alive, but until HG will run on a network 100% of the time, there is still something wrong.

I can run locally, but over the network ONLY works consistently and long term if I disable my private network Windows firewall.

I have added all 3 exe files (HG.exe, HGmanager.exe, & HGservice) to the firewall list. I have the service running. I see HG.exe running in task list. HGmanager seems like a one shot that runs to start the service and maybe this allusive HG.exe then dissappears.

I have tried adding inbound and outbound rules for each program, as well as my port 8316. seems like AHA! THAT fixed it - for a few minutes it is great across the network, then it stops again.

The ONLY consistency I see if turning off private local firewall.

This leads me to believe there is ANOTHER program running I do not know about and it needs to be added to the firewall list.

Does this make any sense? Does anyone know any other programs that need to run to make HG server work?


#18

So is the service stopping with the firewall running or is the firewall just blocking access to the network?

If the service is stopping you may be able to have windows auto restart it.


#19

service never stops. just a firewall blocking other computers from accessing HG webserver - I assume the ‘server’ is HGservice.exe but not sure.


#20

rather than doing a firewall rule for a program, try just allowing tcp/80 inbound initially… Disable things like the UPNP interface and any other un-needed stuff to start with.

(Assuming you are still using port 80)

If you want to do it via cli then click start run powershell (as an admin if offered) if not right click when you see powershell and click run as administrator.

Then run

New-NetFirewallRule -Name Homegenie -DisplayName Homegenie -Description "Allow TCP 80 in for Homegenie" -Protocol TCP -RemoteAddress Any -LocalPort "80" -Action Allow -enabled True -Verbose