HG Hangs on startup 75% of the time


#21

Thanks for ideas. I did not think to disable Upnp in HG; I do have a couple of my camera servers set up as web browsers from inside HG. They DO use different ports!

I did try with inbound, then outbound, port rules using my 8316 port. First time thru I had it working with every program added and both in/outbound ports open for everything (priv,domain,public on everything) even added the 3 exe prog to the in/outbound rules! Once it worked, I began deleting one at a time… eventually it stopped working again, so I figured I found the one I needed; put It back and still no go. then began adding back each one in order that I took out. no go. only turning off private firewall altogether opens it up!

One test was to put HG back on port 80; still would not work.

BUT another thing you bring up: you say TCP for the rules? I thought when I tried TCP it did not work - until I changed the inbound rule to UDP… I never tried TCP again after that… So another good idea I can try!

I am trying to get a port scanner to show me what is going on. I use wireshark on occasion; maybe it will reveal a new clue.

Thanks!


#22

David, thank you very much for your suggestions: I got it!

I just used my port monitor to look at my HA-bridge & HG ports for the first time (8516 & 8316) and it too reports them as TCP not UDP.

It WAS that my INbound rule needed to be set to TCP!

I have now removed all HG program names from the firewall exception list, removed my outbound port rule, and only have inbound TCP port 8316 enabled for private network and have network access again!


#23

you can also turn on logging of the deny traffic on your firewall and then use that to ammend where necessary…

Some stuff such as the HA bridge SSDP discovery will be UDP traffic, the majority of the other traffic will be TCP… (Web traffic etc is 99.9% of the time tcp) UDP is typically ‘brodcast’ style traffic where it doesnt need an ACK. (Over simplifying here before someone pulls me up on this!!)


#24

@mike - I’ve got a hanging system and can’t seem to get it fixed. I did disable UPNP under settings, to no avail. Can you please detail what you did to make this work?


#25

Hi. I never made it work on windows consistently. Many (all?) others the same.

I gave up, bought a $5 raspberry pi zero W card and have it working consistently now x10 forum now has a working SD card image you can download and make the pi work HG right away). It too had same load partially issue but there is a file called hosts that can be modified with name of the pi network name and it becomes rock solid and works. Windows has the same host file (windows/system32/etc/hosts) and someone who still is working with the windows version should investigate it changing it fixes windows also. I moved on. Each time I and others thought we find a windows solution, the lock ups came back anyway. I shows the mod to hosts in my last reply to someone on this forum this morning - search for it and try? Good luck!


#26

Thanks, I just ordered a pi and already have the x10 forum image on a card. My host file on windows contains nothing and when I get the pi up and running I’ll deal with it then.