Help with X10 communications failing

I have been using Active Home Pro for a number of years to control X10 modules. Mostly XPS3 switches and some IR sensors. Like many X10 users, I have been waiting and hoping AHP would be updated. After 4 years, probably not going to happen.

So, I am trying to learn Homegenie, which has many more useful features. However, I am having trouble getting started on the basics.

1.Installed the current version of Homegenie on a Windows 10 machine. No problems that I could see.
2.Went to settings>X10, enabled X10 and added house codes. Using USB to a CM15A. No problem
3.Created a group and added a few switch modules. No problem.
4.Went to the group and tried turning modules on and off. Worked fine at first. Noted there is a X icon in the upper left corner.
5.Now the X icon is off, I can switch the modules on and off, but the modules to not actually switch.

I have confirmed the CM15A ia functional with AHP on another machine. Homegenie appears to be functional. Just not getting from Homegenie to the CM15A. Any help?

I don’t have any X10 device, but have you enabled Event history or tried to look in the logs for some clue?

Bounz explains here how to enable the Event history: Remote control to control lights

1 Like

The X icon will be from the interface. if the interface isnt enabled then you wont have the x and communications, so the interface could be crashing…

Is there anything in the logs? and if you disable and renable the interface does the x re-appear and it starts working (I dont have x-10 either)

1 Like

Stephan and David, thanks for the responses. I have looked at the log as recommended plus some other troubleshooting steps as follows.

Uninstalled HG and deleted the Homegenie folder in \Program Files. Installed HG. Install asked if I wanted libusb-win32 for X10. Clicked yes. Looks OK. One advantage of the install was that the log file is still fairly short.
Shows libusb-win32 installed

In settings selected house code “D”, Device Port “CM15APro” and “Enable” Now, the X icon in the upper right corner is shadowed. Unlike other options that turn blue when true, the Device Port remains black (in the current theme). Also, jumping ahead a little, after I have added modules and try to switch, a pop up shows the action …X10-D5 on.

I tried to confirm as many dumb problems as possible: Power to the CM15A: yes; confirm that CM15A is functional with Active Home Pro: yes; swap USB cables: yes; test machine USB port with other device-thumb drive: yes. homegenie and libusb-win32 running: yes.

So, I toggled X10-D5 and X10-D6 to see whats what in the log file.

I see the following:
2017-11-27 09:41:42.4579 Error System.Exception: X10 CM15Pro device not connected.
at XTenLib.Drivers.CM15.Open()

2017-11-27 09:41:49.3461 Info WebServiceGateway HTTP GET 200 /api/HomeAutomation.X10/D5/Control.Off/undefined/ [OPEN]
2017-11-27 09:41:49.3591 Debug 04-A1
2017-11-27 09:41:49.3591 Warn Interface I/O error
2017-11-27 09:41:49.3591 Debug 06-A3
2017-11-27 09:41:49.3591 Warn Interface I/O error
2017-11-27 09:41:49.3591 Info HomeAutomation.X10 D5 - Status.Level 0

OK the CM15A is not connecting and X10-D5 is undefined.
Not sure what that means. I am thinking there is a simple oversight on my part, but don’t know what to do next. Any ideas?

Hi, @thomas_flemer.
I have no X10 devices in my setup, but may it be possible that your CM15A is being used by another program? In this case, HG will not be able to communicate with the device.

1 Like

done a little digging for you… looks like it isnt finding you device with that ID…


having a gogle finds a link here:

so can you check the id’s of your adapter and we can see if we can tweak the code for you.



1 Like

having said that - if its working at first and then not then it suggests its not the IDs causing the they wouldn’t change.

what do you get in the log after a restart?

1 Like

Thanks David and Alexander for the follow up. I read through the thread on the JVDE Forum. It appears that Bkenobi solved his problem by installing the back up batteries. I normally don’t use the battery backup feature due to overheating of the module. But, did try, no good. However, Bkenobi is running the CM15A from a RPi.

I looked at the XTenlib code on GitHub - it appears to be a HG interface to the X10 Wireless Tech written drivers. Reading the .inf files from the drivers there were comments on code and module removal in the .inf files. It looks like only the included driver will work with XTenlib.

Got a little confusing here, primarily due to non-HG related machine problems, I have installed on three different units. In all cases, HG would talk to the CM15A the first time, but after a logout or reboot, HG would no longer communicate with the CM15A (all machines).

I also ran the NIR USB device program. Sorry for the messy attachment. It appears, if I am reading correctly that both the HG supplied driver and the old CM15 internal driver have loaded. The HG drive appears to be active, but the CM15 version is not. I worked through the Vendor ID “0BC7” USB Device confirms and also checked a machine that is only running AHP, Win Device Manger show the same Vendor ID.

I deleted the old CM15 driver. Now HG is communicating with the CM15. Lights go on and off. Rebooted the test machine and HG returned with the x10 communications still working. Not sure what will cause the old driver to be installed. Will try removing the batteries, unplugging the USB, etcUSB Devices (2.1 KB)
. Any ideas?

1 Like

1 Like

This sounds familiar.
After much headscratching and bad language, i found my com port (yes i have an old interface) had reset itself to 9600 baud, locking up communications. Reset to 4800 baud cured the difficulty.