Ghost RF commands

when reading HG log I am getting daily an rf command x10 E10 status level 1. The only to X10 house codes I have selected are A and B, I have no idea where this command is coming from I have enclosed a copy of the log. Does anyone have any ideas as to what might be happening.

Oh,… I had a lot of this too… it was very very frustrating. I never could find it. I eventually had enough of X10 - after about 15 years working with it… and have now moved to Hubitat with Zigbee - still using HG for a bit of a bridge between the Hubitat and a few old X10 modules I still have in service. Best wishes man… I wish I had an answer for ya but I did have the same problem!

9/7/2019 9:45 AM, kevin via HomeGenie
Club wrote:

  I never had this problem while using AHP it started when I

switched to HG so I just assumed it was HG related. I wonder how
many other users have experienced this? Edjal


              September 7
          Oh,… I had a lot of this

too… it was very very frustrating. I never could find it.
I eventually had enough of X10 - after about 15 years
working with it… and have now moved to Hubitat with Zigbee

  • still using HG for a bit of a bridge between the Hubitat
    and a few old X10 modules I still have in service. Best
    wishes man… I wish I had an answer for ya but I did have
    the same problem!

Visit Topic or reply to
this email to respond.

To unsubscribe from these emails, click here.


If you are using any of the following programs, Smart Lights or Security Alarm check them to see if there is any reference to the codes you mention. I think this was an issue raised on the old forum.

All Security modules have a regular house code and unit code associated with them! Crazy but a fact IIRC. AHP did not show these to you as they wre not important, but if you tried real hard, you could edit a security module and see the house/unit code - even change it.

So if you have ANY security stuff running, those codes will show up when they activate. Remember each DS10 sends a once an hour RF stating it is alive… Perhaps you are seeing one of those?

Hi Mike how are you. Thank You for your reply. I do not have
any security stuff running. All of the stuff that came pre loaded
with HG on the dashboard weather, security and virtual modules I
disabled so I’m assuming they’re not in play. I cleared all house
codes and memory in the CM15 before HG setup. In HG I Activated
the CM15 and House Codes A & B only so its strange that house
code E would show up in the log???

Did you read my reply. Are you saying you have nothing enabled in Programs. If that’s the case you are picking up spurious rf signals either from a neighbor or from some other rf device on your premises. Are you using X10 remotes. Are they programmed with the correct house code. Any chance that one of the keys is programmed with E10. It does happen. Have you isolated a time /date these “ghost” codes are being logged. Is there a pattern.

There’s no mention of what X10 controller you are using so I’m assuming CM15. Do you have any other CM15 located on the premises.

When it comes to X10 HG is rock solid on both rf and pl when it is correctly configured. The exception is the X10 security devices. They’ve never really worked successfully in HG. There’s a couple of hacks/workarounds available but results are questionable.

hello Petediscrete thank you for your reply. I am using the CM15
and I also use the x10 palm pad remote set on Hose Code A. I will
keep track of the E10 commands for a while to check for a pattern.
It seems like it only happens once a day I will let you know in a
few days.

Once per day at the same time would indicate some form of automation routine. What programs are active in the Programs section.

If it’s at random times it’s probably a rogue rf code as I posted earlier. Also check your rf remotes to confirm that each key is doing what it is programmed to do.

One other possibility. Do you have x10 rf sensors in operation. Failing batteries can produce strange results.

X10 E10 it is random times, I took a pic today when E10 happened it activated X10 A1 only scheduled in Dec for xmas tree lights, And B2 which is an X10 MS16 motion sensor. See Attached for pic.
In the program section the active programs are
[(Lights) Advance Smart Lights, Remote control, Smart Lights]
[(Devices and Things) Fun with Flags]
[(X10) Advanced Smart Lights, Driveway Alert Macro, Exterior Pole Light Macro, Set to 100% when switched On]
[(X10) RF virtual Modules mapper]
I have one X10 MS16A Motion Sensor

Change the batteries in your MS16 sensor and see if that cures the problem.

I tested the batteries tested Excellent. I left the batteries out
of the MS16 sensor and I will monitor log for a couple of days
with it out if service to see if MS16 is the problem. Let you know
soon Edjal

Hello Petediscrete I have followed your instructions to test batteries. I also removed them for 24 hours.
I am still getting the ghost commands even while the MS16 motion sensor was taken out of service by removing batteries. The ghost commands are now X10 E2 RF. I have only selected House codes A & B in HG. When RF E2 commands on it also activates X10 A1 which is only ins cheduler to run in Dec. and it also activates the MS 16 motion sensor X10 B2 on. I have provided some of the logs for inspection. Hopefully you can make sense of it.

The only logical explanation I can see is that your CM15 memory is not completely cleared down. I have noticed in the past that it took some users a number of attempts to get the memory completely cleared.

Is the CM15 you are using the only X10 controller on your LAN. Are you using any other X10 software on the same LAN.

Try enabling the monitoring of house code E on HG and see if you are picking up any additional E house code activity on the log.

Just to be clear. In the Programs section what Programs have you enabled. If you are using Wizard Scripts are you sure there is no mention of house code E in them accidentally.

Finally what method did you use to install HG originally.

As per Petdiscrete suggestions I deleted history and memory 8 more times in the CM15, The CM 15 is the only X10 controller, No additional E code activity when activated in HG, however E2 status 1 no longer is activating X 10A1. I never noticed before but the code mentioned with E2 does not match up. My log states The X10 RF receiver raw data for E2 is 20-88-40-12-40. and I could not find any codes that match this. I double checked all scripts and no mention of E2 any where. I original installed HG windows ver to get a feel for the software and later I installed RPi and HG using Tuicemens, Info, then I deleted the windows version. While trying to tweak my macros I ran into additional problems. The MS16 set at x10 B2 just kept repeating on status level 1 about every minute and I couldn’t stop it until I removed batteries in MS16 and disabled all programs in HG, Adv. Smart Lights, Smart Lights, Virtual Modules Mapper (Not even sure what Modules Mapper Does), Set to 100% when switched on. I have since re activated My pole Light macro which uses the MS16 set @ B2. so far running B2 not an issue repeating. I plan on installing batteries next in the MS 16 and setup again to X10 B2 to see if it was the problem if no problem I will enable the programs one at a time and monitor ea. one for a repeat of the B2 repeating its on commands for no apparent reason. Will report back later. Edjal

I’m up and running again, I believe part of the X10 B2 motion Sensor repeating was road traffic even though I’m 40’ away and MS16A spec says it will see only 20’. it was seeing the traffic. I made correction and OK now.
I did notice notice something related to the E2 and E10 ghost problem. If I do an add module setup the E2 and E10 show up in the list of module options for selection even though I only have CM15 House Codes A and B selected in HG Settings. Is there a way of deleting E2 and E10 from HG?

Try a fresh install of HG. I’ve documented how to do this with a few copy/paste commands here

Sounds like there may be some corruption in your HG config file. Doing a fresh install should solve this and you’ll have the latest version of Raspbian Buster along with the latest release of HG.

I’m assuming you know how to create a Raspbian image on an SD card. Just ask if there’s something you don’t understand.

I am presently using HG ver 1.3 stable .5 I had a real difficult time with the image the last time but I will give it another try. Is buster compatible with my RPi Zero W?

Yes. I’m running it on a Pi Zero W at present. Works very well too.

If I use my backed up settings from old HG in the new HG will it corrupt the new HG?