Version 1.1.15 released


#81

I just take an image of my working HG setup. Instead of all the steps required to revert to a working version, if I mess up my install I just reimage the SD card from the working image on my USB drive. All done in 15 minutes unattended.

In fact I have a spare SD card already imaged which allows me to swap it out immediately if the other card becomes scrambled.


#82

ok, sure. i actually have a similar setup on my main unit. I will be doing the same on this one except I’ll have a scheduled backup so I always have the latest config.


#83

I’ve finally stabilised x10 using either the CM15 or the CM11. The XTEN drivers were playing up a bit but that’s all sorted out now.

Using the Home Alarm combined with motion sensors and IP cameras I’ve finally have pictures being emailed to me on motion activation via HG on the Raspberry Pi.

I’d say you notice a performance difference between Pi B+ and the Pi3. Having both Bluetooth and Wifi built in on the Pi3 helps too


#84

I tried using the restore after loading HG via mono command line. Ironically, it worked fine at that point for some reason. I didn’t even see an error, and all loaded correctly.

The only difference between this morning and evening is that I plugged a CM15A in to get the X10 error handled. Maybe that was it though come to think of it. Without CM15A running, maybe the X10 modules wouldn’t restore correctly.


#85

Well, I spoke too soon. Although HG finished the restore and some things are there, all of my X10 modules are not. I see a few motion sensors, but none of the switches are anywhere. Also, I have many missing icons for the weather apps. When I go to the configure -> groups page to see if the modules just need to be added again, it displays a blank list like there are no groups. I’d say the restore only partially worked.


#86

@bkenobi I assume you ran HG using sudo mono HomeGenie.exe in a terminal and watched the output during the Restore process to see the point the restore hangs. From what I gather it can appear to complete the Restore process but can exit with errors.

I experienced something similar recently and reverted to v.526 and solved my problem. I’m wondering if there are some of libraries missing from the v1.1.15 distribution. Just a guess really


#87

That sounds about right. I had an issue this morning with the RPi locking up (unresponsive to telnet, web, and ping). I restarted, removed HG, installed HG. I didn’t try restoring yet as I was working on the install script. I’ll try again later to see if I can get it working or recreate the error.


#88

HG_installation_script_stretch.txt (4.4 KB)
The attached script seems to work well for completing all steps necessary to install HG from a bare Stretch lite image. I tried it and it worked. If someone else could give it a go to confirm that would be helpful. If it works, it should be added to the github files so we can help new users.


#89

That’s fine.

Maybe you could adjust the script to give the user the option to select their own preferences during installation like Locale types, Samba and Mosquitto etc. Otherwise it’s fine.

Also the user needs to make the script executable on their system before running it. chmod +x filename.sh should do the trick.


#90

I considered options but it’s beyond my current capability. As for permissions, I left mine default and simply executed via “sh script.sh” and it worked fine. If the permissions were changed, the file could be directly executed but it would require an extra command that a new user might not know.


#91

Agreed. No point complicating matters unnecessarily.

That script should make life easier for potential HG users.

I’m still using v.526 myself as I haven’t found the need to change this. I did install v 1.1.15 to test it out but found a number of libraries were missing on a particular package I needed.

Let’s see how further updates progress before I install any new version. The one aspect of my install that is being updated regularly is Raspbian. Makes life a lot easier if there are any major changes to the likes of Mono etc


#92

I ran this script manually (copied each line and ran in terminal) and it worked but after doing something with HG 1.1.15 (rrstored setup I think), the whole system became unresponsive. I ran the script and have’t touched HG yet and it’s still running smoothly. I beleive this script is solid but HG may need some work. I haven’t tried 526 to see if it’s a stretch or HG issue though. I haven’t seen any errors as once the issue happens I cannot access the system for diagnosis.


#93

why do you need mosquitto? HG has an mqtt server you can use out of the box…

Personally I think we should split them out into multiple files but looks good :slight_smile:

this is mine currently:

#!/bin/bash

rpi-update # Update Pi Firmware

# Install .NET Core
sudo apt-get install libunwind8 libunwind8-dev gettext libicu-dev liblttng-ust-dev libcurl4-openssl-dev libssl-dev uuid-dev -y
wget https://github.com/dotnet/core-setup/files/716356/dotnet-ubuntu.16.04-arm.1.2.0-beta-001291-00.tar.gz
mkdir ~/dotnet
tar -xvf dotnet-ubuntu.16.04-arm.1.2.0-beta-001291-00.tar.gz -C ~/dotnet
rm ./dotnet-ubuntu.16.04-arm.1.2.0-beta-001291-00.tar.gz

# Install Powershell 6 core (optional)
wget https://github.com/PowerShell/PowerShell/releases/download/v6.0.0-rc.2/powershell-6.0.0-rc.2-linux-arm32.tar.gz
mkdir ~/powershell
tar -xvf ./powershell-6.0.0-rc.2-linux-arm32.tar.gz -C ~/powershell
rm ./powershell-6.0.0-rc.2-linux-arm32.tar.gz

# Optional HG Pre-reqs - uncomment as required
#sudo apt-get install alsa-utils lame -y # Audio playback
#sudo apt-get install libttspico-utils -y #Embedded speech synthesis engine
#sudo apt-get install lirc liblircclient-dev -y # LIRC Infrared interface
#sudo apt-get install libv4l-0 #Video4Linux camera
#sudo raspi-config nonint do_camera 0 #enable the camera
#sudo modprobe bcm2835-v4l2 # enable camera
#sudo apt-get install libusb-1.0-0 libusb-1.0-0-dev # X10 CM15 Home Automation interface
#sudo apt-get install arduino-mk empty-expect # Arduino programming from HG program editor

# Homegenie-BE
sudo apt-get install dirmngr -y
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb http://download.mono-project.com/repo/debian raspbianstretch main" | sudo tee /etc/apt/sources.list.d/mono-official.list
sudo apt-get update
sudo apt-get install mono-complete -y
sudo apt-get install ca-certificates-mono -y
sudo apt-get install gdebi-core

# Download and install Homegenie-BE
wget https://github.com/Bounz/HomeGenie-BE/releases/download/V1.1.15/homegenie_1.1.15_all.deb
sudo gdebi homegenie_1.1.15_all.deb


#94

I installed mosquitto before HG had a MQTT option built in I beleive. I later tried that option and couldnt get it to work. If there is a simple guide for that, I could switch over as I have no connection to Mosquitto.

I also tried using rpi-update to get the current firmware. It crashed the SD card 2x (could have been something else that caused it). I also read that as of some Jessie version, the firmware update is automatically performed (cannot confirm).


#95

Yes they don’t really advise doing a firmware update manually these days. If a firmware update is required the sudo-apt get update/upgrade usually handles this.

Assuming you took an image of your working installation before this operation I’d reimage your SD card now.

There has been reports of people bricking their Raspberry Pi while attempting to manually upgrade it. Hopefully this is not the case with yours.


#96

The RPi is fine. The SD image was toast though. I started over with flashing Strerch and was back in business.


#97

That’s good news.

That’s why I keep a spare SD card with a working version of HG close to hand for situations like this. I can experiment to my hearts content and just swap them out when one of them crashes.


#98

Thats what i do with my main RPi. I have 2 backups of that when bad things happen. Im going to do the same here and use 1 or 2 of the usb for backup cards in adapters.


#99

I was just about to add a couple things to my setup to verify it will remain stable over time. One thing I looked at was the MQTT service within HG. It looks like it’s based on GnatMQ. According to the github repository, they don’t actually recommend using that as it’s not well maintained. Is it possible HG should be updated to use a different MQTT broker/client? I have no affiliation to any of them and only use Mosquitto based on a thread I read on the HG forum a long while back about how it was a good option.


#100

Yes, but I have never used MQTT so I don’t know what would be the best replacement.
If you find good and actively maintained library for MQTT support - feel free to open an issue on the GitHub or post somewhere on this forum.