Version 1.1.15 released


#61

Absolutely agree. I’m working on integrating Alexa at the moment and slowly adding functionality to it. The Raspberry Pi is definitely the way forward HA wise. I’ve a Rock64 on order at the moment so looking forward to seeing what it can do.

I’d like to stay with HG but I need to know that I can solve problems and come up with solutions. I’m not really into the esoteric stuff and I’d hate HG to go the way of the “anorak”. We’ve got to keep things simple so users feel like they can contribute. Here’s hoping we get there eventually.

You contributed quite a lot to the old forum and I hope you can continue to do this.


#62

I followed your instructions from the start again. When I get to the mono installation step, I have to change the command for the mono location because the double quotes didn’t work on my system. That could just be due to my browser I suppose.

Either way, after running update, I check to see what version of mono is installed and I can’t find it at all. Running “which mono” shows no results. “mono --version” returns an error because mono isn’t installed.

I’m currently trying to install mono the way I have in the past to see if that works better.

sudo apt-get install mono-complete

EDIT: Got it! As I expected, mono wasn’t installing prior to HG install but it was there after so it must have been completed with the dependencies. For some reason it must have installed the wrong version even though I had v5.8.0.108 and this time I have the same. I’m going to suggest installing mono-complete prior to HG in my instructions.

As a side note to Bounz or whoever is working on the fork: I see that HG comes preconfigured with a bunch of modules as always. Is it possible to have a version available that doesn’t have all the junk already installed. For instance, I see that lirc is installed with HG but I have no need for it in my setup. I will turn it off when I get to my setup, but I have no need to have the library installed in the first place.


#63

Great to see you got it up and running. It will solve all those nasty email notification issues.

Are you going to restore your settings from a previous version or start from new.

I’m looking forward to more users coming back on board with practical solutions to everyday HA problems.

Hopefully more users will upgrade their Raspberry Pi systems to Stretch so we are all on the same page when it comes to troubleshooting.


#64

Yes, I hope it will be done at some time: https://github.com/Bounz/HomeGenie-BE/issues/23.

If anybody can change installation instruction and create a pull request to the https://github.com/Bounz/HomeGenie-BE/tree/gh-pages branch - that would be great!


#65

Well, I may have spoken too soon. I was up early this morning and got HG up and running. I went back to bed for a few hours and just checked again. The RPi is unresponsive. The red light is on, but the green one is only flashing once every few seconds (I don’t know how this compares to the RPi1 which always had a green light on when it was running).

Either way, I can’t connect to it via ssh or browser, so I can’t see what the error is. I think I’ll try the same process and install 526 to see if it also locks. I have a second card for this setup, so I can keep the 1.1.15 version intact for now.


#66

Have you set up the Pi to run from boot or are you starting it from the terminal. Strange it just crashed for no reason.

May be worth checking out the Systemd method of starting HG as a service. Homegenie is configured to start with the old init scripts as far as I know.


#67

Assuming I can get a card to work as expected, is there a way that we can convert individual commands into a script that a newer user could run on the RPi without having to copy/paste so many lines? It seems like we might be able to make it simpler for a complete Linux newbie if that were possible. I don’t think the raspi-config step is needed, but all other steps would be good. Either that, or a writable image with HG ready to go (similar to what Gene provided early on with HG).

In the end, users need to become comfortable with their HA setup, but there may be too much of a learning curve with RPi for many to want to invest the time.


#68

FWIW, I used my second SD card and installed stretch on it with HG 526. For some reason, HG crashed and would not run (I think it was a database issue but not sure). I uninstalled HG and installed 1.1.15. I’ve been letting it run for a few hours and it’s still running, the RPi is still responsive, and the web interface still loads. I’m going to give it til morning and try checking again (if I have time, tomorrow evening if not).


#69

yes, you can create a .sh file which contains all the commands :slight_smile:

Image should be do-able too but might have to use travisci to do the build for that as opposed to appveyor.


#70

The system is still up and responsive this morning (both ssh and web). I’ll back up my current HG setup and restore it on this new one to see if it works for a few days. If so, I’ll probably swap this new setup in later this week as the primary.

The goal of this was to improve web response speed. I compared a load from my RPi1 to my RPi3 and while it’s a bit quicker, I probably wouldn’t have bought a new RPi just for the speed advantage. That said, having 4 USB is a big bonus as I really need 3 and didn’t want to use a hub.


#71

Yesterday I faced the same situation, but after a short investigation, I found that my wife unplugged ethernet cable :joy:


#72

I’m accessing the Raspberry Pi via Ubuntu Xenial using Firefox. Web pages loading fine and everything seems to be working ok.

Are you experiencing any bottlenecks on your system. I’m running through a 360Mb fibre connection so it helps to rule out speed issues.

I’ve dropped back to v526 as the MIG Packager seems to be missing files on certain packages.

Obviously there is three download options for Homegenie, Windows, Linux and OS X. Have all the relevant files been fully packaged in the MIG Package installer for each version. Dropping missing files into folders manually isn’t an ideal situation.


#73

I haven’t done any network benchmarking recently. I did some a few years back when I set up my file server to verify it would be able to do the job. My router is a Linksys WRT54G running DDWRT so it’s limited to 100mbps. I wasn’t aware that the RPi3 was gigabit, but serving a simple web page shouldn’t bottleneck a 100mbps connection anyway.


#74

Chrome is a little slow but Firefox is running well.

I’m assuming that with very little development work being done on the core HG product it’s not going to benefit from any new features in the browser world.

I’m 90% working as far as HG is concerned. My last challenge is to get the Raspberry Pi on board camera module working. It was working in Wheezy but for some unknown reason stopped in Jessie and still not working in Stretch.

I’ll change to v1.1.15 as soon as I fully finished my test system.


#75

it isn’t gigabit…

The packaging is new so bear with us… I knocked that up and it took a fair bit of time but will allow us all to turn releases around quickly and also execute the unit tests as the code evolves.


#76

Just a little update. HG has been running on my RPi3 for about a week without issues. I didn’t move it to my primary HA yet as I was having issues restoring the settings from that unit. Is there anything changed regarding backing up or restoring that I should be aware of? It looks like HG just sits there with the “please wait” message forever without any change. I restored last night and this morning the password was changed but none of the modules/programs/etc were different from what the factory settings had.


#77

@bkenobi what version of HG are you running now.

It might be worth starting HG in a terminal session using sudo mono HomeGenie.exe and perform your backup/restore operation and see exactly what is causing your system to hang.


#78

1.1.15 on the RPi3. The one I’m currently using is an RPi1 running 525. I tried a factory reset and it hung for 30+ minutes. I’ll try watching the live output like you recommended though.


#79

I tried a restore from a newer release onto an older release recently and the system hung during restore. Traced it back to newer libraries being loaded onto an older system. Got the dreaded Sigterm error. I just reimaged the SD card and restored the correct backup.


#80

I’ll have to see what it says. Out of curiosity, why did you have to start over with the SD if HG got messed up? My experience is that simply uninstalling and deleting the HG directory prior to a fresh install is sufficient.