Undefined Modules on power up start


#1

After each computer reboot, I notice all my security modules show up as “undefined.”

I now see that about 1/2 of all my other modules show up as “undefined” also.

Further, they repopulate their proper names and add the on/off buttons, AFTER that device activates. Security modules transmit RF every 20 minutes to prove they are alive, so after about 30 minutes, all will have activated.

BUT the “undefined” does not go away until AFTER I go to config, groups, and open that group to look. They are defined and I close and go back and all is fine again. Until next power down/up.

I can RESTORE a past file and that does not change it. Only external activation then going to group config page and out.

This morning I wondered if it may be a permissions issue on the HG program directory so went and looked: full permission was not on all users so I added it. Will report back if that fixes it.

Anyone else have this?


#2

Where is HG installed?
I know your running Windows but which version and is it 32 or 64 bit.
The 64 bit versions have more security in place for the Program Files folders which many programs have difficulty with.
Security modules depend on their check in feature to define them I’ve also seen these reported as undefined on a reboot until they check in. and this is on a Pi
Other modules I have don’t have this issue, that I recall.


#3

Sounds like a dependency issue. I think Bounz fixed this in v1.1.15


#4

That may be true in my case as I’m still running Genes last build.


#5

Is v1.1.15 newer than v 1.1-beta526 dated 8/19/2017?

If so, where can we download it?


#6

@mike, please, don’t use it, as it has known issues (at least on unix systems) :blush:, you can find them here on the forum.


#7

@Bounz I think he’s using Windows. Not sure what version but he should be ok to your beta. I assume you are using your own version :laughing:


#8

Of course, and what is more, I use the dev version which is not stable sometimes))

Anyway, feel free to try V1.1.15 if you have some free time, but personally, I don’t think that it will help you with undefined modules on startup. I’ve seen this behavior when I unplugged my Z-Wave dongle from RPi and restarted HG. So looks like HG needs to communicate with the device to properly initialize the corresponding module. But it looks strange to me, that after restart only security modules become undefined.

Unfortunately, I have no X10 devices so I can’t even try to reproduce this error.


#9

Usually refreshing the web api resolves this. Different browsers give different results. Firefox doesn’t display this behaviour. Again using Linux so I can only comment from a Linux perspective.


#10

I believe in my windows 10, 64 bit, ALL browsers equally show undefined on reboot. Refresh does not bring them back on my computer. To define again, the security module must transmit and be seen by HG AND go into config,groups, and go into the group with the undefined modules. Both these are required to define them.

FYI, I can do the same with regular X10 non-security modules - in case this gives a clue how to fix it: config,settings, x10 - unclick a house code I have modules on. go back and look - they become undefined. Go re check that house code, and the undefined goes away. Maybe this would help a programmer figure out why.

Since I do not use the HG security function (yet), this undefined is not a big deal to me.


#11

Pete, I did not read ANYTHING about such dependencies being corrected in 1.1.15. Where do get that information?


#12

Bounz, the difference between security modules and no security modules is this:

  • security modules MUST BE SEEN once to identify them and add them to the module list.
  • non security modules are automatically ADDED to the module list whether seen or not - by the x10 program where we tell it which house codes are valid.

I may not be an original C+ programmer, but I am very good at finding problems.

Distinct difference.


#13

The secret here may be that they are X10 security sensors you use and not standard X10 ones. The only RF X10 sensors I’ve ever used are the MS13E and they show up as defined every time.

You’ll have to drill into the relevant code in X10 to discover what is causing your problem. Do you have standard X10 sensors you can use to help troubleshoot this problem.

@bkenobi may be able to shed some light on this issue when he reads this.


#14

I use MS16A which are also not security sensors. I only have door for security sensors but have never unboxed them. I recommend contacting Gene if you have a question about the implementation of security sensors in HG. The rest of us are guessing really since we don’t have the hardware to experiment with.


#15

@bkenobi apologies for tagging you there. You did some impressive work on X10 previously and I thought you may have used X10 security sensors in the past.

I do know some member on the old forum was tinkering with them at one stage but was definitely having problems integrating them fully with HG. An additional layer of protocol he couldn’t identify I think.

He found an extra layer of hardware he could add into the mix to translate the code but it was more trouble than it was worth. Timing issues if I remember correctly.


#16

I think @Bounz has answered that one now.

I do know there was a problem with camera modules being undefined so maybe that’s what he resolved.

So many problems. So many solutions :laughing:


#17

No problem. Even though I have not personally worked with all the flavors of this or that tech, I often do a lot of reading on random topics. I’ve been known to know more about other’s setups than my own at times. :rofl:


#18

@bkenobi like yourself I have a working X10 system on HG. The only real changes I’ve made recently was putting it on Raspberry Pi Zero last year.

It just stays in the corner out of sight and works.

We definitely need to get it working beyond Mono 5.6 though or will end up with the SSL certificates issues again.


#19

I spent many hours trying to get a stable BE version working on my RPi3. I never got it stable enough to trust replacing my 526 on RPi1 though. I haven’t worked on it in months hoping there would be some progress like in the old days, but I haven’t seen much. To be fair, the site is blocked from my work computer and I don’t spend a ton of home time online this time of year.


#20

Same here.

Like yourself I tied Into Mono 5.6 and eventually reverted to v526. Its as stable as can be expected for software that lacks any real serious development in nearly two years.

I leave well enough alone until fall/winter and have another look then. Too much to be done outside at this time of the year.