Turn Off Delay time setting issues


#1

I have some Z-wave relay modules that I’m trying to use as garage-door openers. To do this, I need to simulate the momentary ON of a push-button switch.

Looks to me like “Automatic Turn Off” should do this, but I cannot seem to get the front end to let me set an appropriately small value, like 1 second, or even 5 seconds. It seems like any number under 36 seconds is completely ignored.

I thought to try editing the module parameters in the XML file, but when I ran into this, I figured I’d better stop:

  <ModuleParameter>
    <Name>HomeGenie.TurnOffDelay</Name>
    <Value>jw3krUjh8lyEeXmB4UQERg==</Value>
    <Description />
    <FieldType />
    <UpdateTime>2017-12-09T19:59:05.804727Z</UpdateTime>
  </ModuleParameter>

Why is the Value not simply an integer??? Currently, this module’s Auto Turn Off delay is set to 36 seconds, and it is working, but it’s far too long to be sensible for this application.


#2

Genie made values stored in Base64 encoding after another crypto encoding :joy:
I don’t know what was the reason, but here is the source code: https://github.com/genielabs/HomeGenie/blob/master/HomeGenie/Service/StringCipher.cs.

About “Automatic Turn Off” - it’s slider widget wrong behavior, it evaluates delay value with steps of 36 and sends to the server wrong data.
The easiest way to fix it is to edit “Automatic Turn Off” program and on “Startup code” tab change the value 3600 to 100 for example.


#3

Thanks! That solved the problem.

Is there any way I can avoid having to re-edit this if/when I install a homegenie update?


#4

Theoretically, you should not lose local modification to the programs during the update process, but I can’t guarantee it 100%.


#5

I advice against making any changes to programs with Id < 1000. I had them overrided in the past when updating HG once at least .
I would copy the program to a custom program (with Id > 1000) then disable the stock one (I also did this with this program because of the opposite issue: I wanted to specify a period longer than 1 hour).
Regards