Trouble with DHT-22


#1

I had to reinstall everything on my RPI B+ I installed Raspian Stretch and this in one problem I’m having.

I’m getting this error message:
“Specified argument was out of the range of valid values. Parameter name: processor”

Any ideas?


#2

Hi Claton,

I am having a similar problem with my DHT11. What I digged up so far is:

  • The Kernel Change from 4.8 onwards changed the way the chipset is being reported
  • home genie makes use of the raspberry-sharp-IO library to control GPIO
  • the current version doesn’t expect the new chipset naming of kernel >4.8
  • changes need to go in to raspberry.system and GpioConnectionDriver.cs

See: https://github.com/raspberry-sharp/raspberry-sharp-io/issues/88

But I got stuck there in how to compile the two, maybe you have a clue?

Best regards
Jens


#3

Hi Jens,

I suspected something like this. The solution is to go back to Jesse, that worked and that’s what I will try next. I’ll let you know how it goes.

Clay


#4

Didn’t work going back to Jesse. The reason is Jessie now contains kernel 4.9 too.

I downgraded to kernel 4.4.50 and things seem to be working.

I found the instructions for doing this here:


#5

Doing a kernel downgrade is unfortunate no option for me. I had regular reboots of homegenie because of USB kernel issues. They were not linked to homegenie as such, more a basic OS problem. Since I upgraded the kernel they seem to be gone (this is what I found as comments in various forums, too) until now.

I found two forks

and

Raspberry.System contains the Info for the 2835, but in uppercase BCM2835.
Raspberry.IO.GeneralPurpose expects them to be as Bcm2835. I tried to fix that in the code with XAMARIN, but Raspberry.System is linked as package via nuget.

Would be really helpful if somebody would know how to go beyond that point.

Many thanks
Best regards
Jens


#6

I just experienced the USB problem. I didn’t have the problem before. So I restored from the recycle bin the version of Raspbian I had great success with from 2016. I intend to go back to that version. So wish I had remembered to shut the pi down before I pulled the power! I’ll report back in a week or so on my results.

Update Jan. 15th: Haven’t had the USB lock again so haven’t gone back to older Jessie. Still using kernel 4.4.50.


#7

Hi!

I’m having the same problem. Thanks for help!

Nacho.-


#8

Hi,

I was able to compile now by changing all relevant entries to

case Processor.BCM2835:
return Interop.BCM2835_GPIO_BASE;

I haven’t exchanged all DLLs on the Pi yet, as I wanted to do a backup first.

Will try in a couple of days

Best
Jens


#9

Goodmorning everyone!
… Please, has anyone managed to solve the DHT-22 problem with Raspberry P3 and Raspbian Stretch installed?