Scheduler Issues

Yes, me again.

Everything is working fine, but the last of my ActiveHome Pro died during a recent Windows 10 update. Everything *timers, macros) were on that program and would no longer function. I now have the macros functioning on HG but have been struggling with the scheduler for the last two weeks

This is what I would like to do.

A4 is an AM466 appliance module controlled by (in theory) cron.
A1 is a motion detector to a TM751 PL interface
A4 is plugged into the wall socket, the (a1)TM751 is plugged into the (a4)AM466

This is what I am trying to do.

if a4 on then [timed}
if a1 on then [motion sensor]
output d2 [garage/outside lights] on then
wait 5 minutes
output d2 off

This is what happened once with sundown/sunup. A4 on from sundown - sunup but only (at the most) on for 1 minute, then off

Using scheduler set for time on/off in HG the A4 unit will not react to time settings.

A1 MS16 motion detector works quite well when connected through plugin timer but we are far enough north I need to manually reset the timer about once a month to keep the light working properly. In June we have light 5:00AM until 10:00PM. December 9:30AM till 4:30PM so there is a wide range of daylight hours. Cron would be the ticket, but it doesn’t seem to work right on my setup. do I need to install any of the program groups or widgets? Possibly SmartLights? How do I do that?
Is there perhaps a different way to set this up that I’m just not seeing?

Thanks again for all your help.

HG v1.3-stable.19

HG Wizard will handle all that logic for you. Just break down your logic into smaller subsets as it simplifies things. Try keeping the logic as simple as possible. You could of course install Advanced Smart Lights. That simplifies everything really. You can grab it from here HomeGenie_Apps/Advanced_Smart_Lights.hgx at master · bkenobi/HomeGenie_Apps · GitHub

Thank you very much, I’ll give it a try.

I had included a timer override at one point so that the lights could be on at sunset and off at a set time and then motion override after. I decided I didn’t need it so that capability is not there. Given some interest, I’m sure it would be easy enough to add back in by an interested party if needed. I don’t have the old source anymore due to a stolen laptop years ago which is why the source resides on GitHub now.

Thank you for the info. I am still working my way up to newbie so we’ll see how this all works out.


I think I found at least part of my problem. I had not setup the RPi to the North American time zones so my poor little pi was getting confused. At least now the timers are showing something other than confusion. Thanks again for the help. Still going to try the SmartLights, but I have had enough of today.

In case its of any value, I found it hard to cron both on and off in the same schedule, so I have broken that into 2 schedules; one for ON and one for OFF. Then I could add redundancy to be sure the commands ‘took.’ Here is my typical setup for on/off range:

The the cron:




Thank you, Mike. This is Exactly what was needed to steer me back onto the proper path. It is working now. Now I get to play with this and really disturb the wife.

As I mentioned above keep your logic simple and break the tasks down into smaller events. The ands and ifs only confuse the issue.

As you can see you can call an event (script) based on the results of another event (script) so that covers all bases.

I suggest you have a good read of the documentation too. You’ll also find numerous examples on YouTube and the old HG forum.

This morning I noticed something unusual. To me,anyway. The setup I did for scheduler I setup worked very well on a TM751 transceiver but the instant I replaced the TM 751 with an AM466 the module would turn on for 30 seconds and then turn off. During the timer range if you turned the module on it would stay on for the thirty seconds and turn off again. I can change out units and make it work, but is this the correct behavior? Have I found a new way to mess up? This is not something critical but it is confusing, at least to me

I was told as a child I would go through life pulling on doors marked push. They were right.

With the original scheduler it would look for the minute the event was called and perform the task. The scheduler ran at 30 second intervals, so the event would run 2x, 30 seconds apart. I’m not sure if that was changed in the newer scheduler but that may be what you are seeing. If you have an event that turns on a module and you override it within the first 30 seconds, it will likely be turned on one time.

From what you describe, this sounds like a likely source of your observation.

I finally remembered a lesson I forgot about LED lights and appliance modules. You need a regular incandescent bulb in the circuit before the module will stay off. I plugged in a single nightlight and problem solved. At least until I replace the appliance module with the proper switch.
Just passing this along.


Just recently ditched all my lamp modules for the same reason.That was the end of the dimming function. No need for it now anyway.

LEDs are working fine on appliance modules at 5w or greater. Anything below that are still glowing after they are turned off.