Schedule Aeotec Smart Strip

Hello, I have a Aeotec Smart Strip. I am having trouble configuring an individual receptacle (Instance) to turn on or off in the Scheduler using the cron event wizard.

If I enter: $$; , all receptacles on the strip turn OFF.

If I enter: $$.boundModules.on(); , all receptacles on the strip turn ON.

How do I configure it to turn off the first receptacle (Instance 1)?

More info: If I enter the widget settings, Setup, and scroll down to Multi Instance Channel, I can manually individually turn on and off each receptacle (Instance).

Also tried:$$.boundModules.Command(‘MultiInstance.Set/Switch.Binary/1’).Set(0); The light plugged into the first receptacle (Instance 1) did not turn off.

Any help would be much appreciated. Thank you.

Well, @Dave, the command definitely should look like
but maybe I was wrong about the numbering of instances and they start from 0.

So for the first instance it may be this:

Also, if you have time, please give it a try and check this commands with different sockets in Smart Strip. For example, if you have a number of table lamps you can plug them in simultaneously and then check which one will turn off.

Thanks, I’ll give that a shot. I know when I go to the widget settings, Setup, and scroll down to Multi Instance Channel, I can turn the first socket on and off with instance 1, and the second socket with instance 2. To set it on, would it be 1 or 255?

I do have another issue I have to fix first. I set the password, and it has crashed HomeGenie, The web interface page wont display.

Hmm, it’s quite strange.
I checked the code of Setup window and it emits the same command I told you the first time (with instance Id = 0).

Are you sure that you have correctly configured a schedule item and bound devices to it?
I’ll try to find is there any logs related to starting schedules and emitting commands to devices.

I’m fairly sure, because $$; will turn off all the sockets on the strip, and $$.boundModules.on(); will turn them all on.

Well, it’s good that scheduler works, but, unfortunately, I don’t have any multi-instance device to test it on my on.
About turning instance on: use value 255.
Could you please make some experiments as I offered earlier and write results here?

P.S. According to the documentation, this device should work with following commands:

  • Basic set 0x00/0xff
  • Switch Binary set 0x00/0xff
  • Scene Activation set 0x00/0xff

So, it has to respond to the Switch.Binary command…

I deleted and recreated the schedules and it works, exactly like you described:

Socket 1 (Instance1) OFF = $$.boundModules.Command(‘MultiInstance.Set/Switch.Binary/1’).Set(0);
Socket 1 (Instance1) ON = $$.boundModules.Command(‘MultiInstance.Set/Switch.Binary/1’).Set(255);

Socket 2 (Instance1) OFF = $$.boundModules.Command(‘MultiInstance.Set/Switch.Binary/2’).Set(0);
Socket 2 (Instance1) ON = $$.boundModules.Command(‘MultiInstance.Set/Switch.Binary/2’).Set(255);

Thank you VERY MUCH, I really appreciate your time and patience.

Glad to help you!

But anyway it’s strange that you had to recreate that schedules…