Programs.xml 0 Byte

after saving some changes to a program, i found the Programs UI completely empty.
Checking in the HG folder, the programs.xml file is 0 bytes.
The bad part is that I don’t have a backup, and I have a lot of 10-day work changes…

I apologize in advance if the question is meaningless:
Is there a way to generate the programs.xml file from the dll and mdb files of the programs directory?

Have you tried stopping the service and rebooting. I’ve seen this before which I managed to resolve with a Backup/ Restore. Sounds like a file corruption.

You could take an image of your SD card before you try the following :-

Perform a backup from within HG and then restore this backup. This action might force HG to rebuild the files you mentioned.

Prete, Thank you for the suggestion.
I tried to stop and restart HG, but nothing.
Then I also tried to create a backup to see if there was anything in the programs.xml file and finally I have delete the programs.xml file, but it was recreated without the programs inside.

Now I’m doing the restore as you suggested… I’ll let you know if it worked.

You possibly have a failing SD card. Have you checked your log files for possible answers.

If you deleted the Programs file before you did the Backup/Restore I doubt you will be successful but try it anyway.

I’ve always made a point of doing backups after I carried out work on HG but you know that anyway now.

Also take regular image copies of your SD card. You can always use Pi Shrink to reduce the size of those images for storage purposes.

I have not deleted the files in the programs folder (dll mdb). I only deleted the 0 byte programs.xml file (after making a copy anyway).

Trying to restore, a window warns that there are no user programs in the restore. Confirming only 3 Weather programs (Jkutils…that I do not use) have been restored.

It looks like your Programs file got corrupted during a Save action so. Possibly a bad SD card.

Have you checked your logs yet. Are they quite large. The constant logging to SD card doesn’t really help either.

On the Raspberry Pi 3+ I ended up transferring my Raspbian/HG system to an SSD drive which boots directly on the Raspberry Pi. Everything appears to be a lot more stable.