Power monitor program

#1

Is there a way to stop the power monitor program ? I don’t need it and it is writing to the MicroSD card every couple of seconds.

#2

Try to disable Energy Monitor program in Programs - Energy Management group:

#3

Energy Monitor is already disabled

#4

I dug into the source code and the news is bad: the only way to stop these events is to manually edit modules.xml file.

The problem lies in VirtualMeter that every 30 seconds iterates through modules and if a module has parameter VirtualMeter.Watts then it raises an event on property Meter.Watts.
But, as you can see in the code for updating module (https://github.com/genielabs/HomeGenie/blob/master/HomeGenie/Service/Handlers/Config.cs#L739) you can’t change parameter VirtualMeter.Watts as it is translated into an update of Meter.Watts parameter :man_facepalming:

Created an issue on GitHub: https://github.com/Bounz/HomeGenie-BE/issues/66

So you have to shutdown HomeGenie, then edit modules.xml and remove <ModuleParameter> element with name VirtualMeter.Watts, save the file and then start HomeGenie again.

#5

Thanks Bounz for your help.

It seems that the modules.xml file is regenerated somehow. I deleted the lines and they re-appeared. And the Meter.Watts lines still shown in the log.

What is also strange, is that I have other ZWave and X10 lamp modules and they are not showing in the log.

#6

It means that you never touched VM Watts field in their settings:
image

Are you 100% HG was not running when you changed the file?

#7

You are right about the VM Watt field. I took a module that is not in the log and change the field to 10 watts. It appeared. I put it back to 0 watt and it stil appeared.

I stopped the service before editing the modules.xml file, . Is it enough ?

#8

Yes, it should be enough.

#9

I have finally been able to get rid of these “Meter.Watts” written to the log.

I have enabled the program Energy Monitor in the Energy Management programs group.
Then, I set the VM Watt field to -1. If I set this field to zero, the next time the Energy Monitor run, the field is set back to its previous value and a line is written to the log. By setting the field to -1, HG change the value to 0 but does not modify it when Energy Monitor runs.

1 Like
#10

Update :
No need to enable Energy Monitor (as it seems to be running even if it is not enabled). Only setting the VM Watts field to -1 do the job.