Lame question on time zone


#1

Sorry for the stupid question- I cant remember how to straighten things out after daylight savings hit…

The Pi has the correct time but HG is reporting one hour off.

Where do I fix that?

Thanks!!!


#2

Interesting question. There is no setting for in HG for time zone that I am aware of. Hope David or Alexander can sort it out.

My RPi3B with Stretch and HG r526 ran during the switch to DST. Checked homegenie.log and the gui, all looks good here. The only thing I remember doing on Sunday was to restart my browser linked to HG. This was unrelated to DST. I am guessing that you have rebooted the Pi and your browser. What do you see in the log?

cat /usr/local/bin/homegenie/log/homegenie.log


#3

Kevin,

Where do you see wrong time? Last update time in widgets, in the scheduler, somewhere else?
Also, please report what version of HG do you use?

I think that Thomas’ suggestion to reboot RPi will solve the problem.


#4

The time zone is probably defined by using the longifude and latitude found in the system options of HG.

There is an error in the scheduler everytime we go in and out of the daylight saving time. I suppose that the Sunrise and Sunset times are set at the beginning of the day (00h00). So, all the expressions of the scheduler based on sunrise and sunset are also set at 00h00. The time change occurs at 02h00, That is why RPi time is correct but scheduler is off one hour
The scheduler will be correct the second day after time change.


#5

HI All- I am on R525 and I dont really SEE the time issue… I just notice it b/c my events are happening an hour off.

I will try to reboot now! Thanks!!!