Installation problem

Just installed HomeGenie. The interface opens but I only see one widget, the outside temp. (not configured). Not what I expected according to the documentation. Now I want to add my ZWave modules to the system. But again according to the documentation, I should be able to do this in settings/ configuration. But I still dont get it. I dont see any interfaces. I had HomeGenie on it ebfore, so I wonder if there was something still hanging around that causes this.

What source did you use to install HG from.

It sure sounds like you got a corupt install as any install I’ve seen includes several demo modules.

HomeGenie_v1.3-stable.4.exe from the download page.

What have you installed HG on (windows)?
The current version is 1.3-stable.5 if you can navagate to the mantenace screen do a update.

I will try that. Is there somewhere anything left after an uninstall? Maybe the configuration?

Weird things going on. I type Homegenie in the Windows search box: it shows “HomeGenie 1.2-dev” app.I check the file of this shortcut and it is indeed called that way, but it does point to the exe in the directory that I selected when I run the install using the 1.3-stable mentioned above. Checking the details of the executables dont help as they all still mention as version. SO not sure what version is out there. I then run homegenie , the browser opens with the full ‘demo’ dashboard, something that was not there yesterday (The miracles of a Windows reboot). Going to maintenance and “Update check” results in a “InstallProgress.Update ERROR”. I found the “About” in the browser interface, it does say there 1.3-stable.4 . But the Update Check there results in the same error.

There are files left after a uninstall of any thing from windows.
These are typicaly files that are created after the install proccess. Since I don’t run HG on windows I have know Idea if it leaves addon programs you may have installed after HG. Im not even sure where HG gets installed in windows but suspect it is in programfiles x86 if your running a 64 bit system. I’m not sure how long ago you had HG installed or for but it does sound like you have a conflict with old settings.

This is what I would do. Locate where HG is installed then uninstall it once it is uninstalled delete the HG folder if still present. I’d also clean out the windows registry (however if your not comfortable with that don’t attempt it) reboot. There are some registry cleaners available but None I’d recommend
@Bounz may have more info on a uninstall and reinstall on windows.

It looks like everything is there and working now, except for the “Check Update”. I did do an uninstall, delete all directories and check the registry before I did the latest install. Anyway I am good to go. Maybe there is a link to the stable.5 upgrade , so that I can install it from there? Thanks

The stable.5 version is on github under releases.

It has been years since I ran HG on windows but it has improved considerably since then. Other’s still state they have problems, these are mostly new users I think.
I moved to running HG on a $5 raspberry pi a couple years ago and not looked back. I think most user are tending to move this way.

I will be running it on a raspberry. Is it running the linux version? I looked at that briefly and wondered why it was .net framework and not .net core.

It uses the raspbian lite version. There is no desktop GUI. I created a image with help from others here that will install the Buster OS, HG, and HA-Bridge. The whole process takes about 20 mins depending on ones internet connection.

I don’t use HG on Windows platform, too. But HG doesn’t use Windows Registry at all, maybe installer use it, but it should not be a problem.

I’d recommend to use .tgz archive and simply extract files and overwrite your existing installation (don’t forget to save your settings). It’s the same executable homegenie.exe used on both platforms Windows and Linux. The only difference is that Windows installer registers this files as a windows service (so it starts automatically when system boots) and also installs a little helper program that resides in system tray and allow you to control those service and open a browser.
You don’t have to stick with that windows installer. It’s super easy to register any executable as windows service using small nssm utility ( and control it via Services panel (Win+R -> services.msc) or Task Manager (Services tab).

Gene wrote core code many years ago when there was no .Net Core at all.
I had idea to rewrite it, but there is a number of dependencies that have to be updated to .Net Core too. This weekend I’ve opened a PR to serial-port-lib that allows to use it in both .Net Framework and .Net Core applications (

The current HG gdebi installer for Raspbian Buster is currently broken. I prepared a list of simple instructions last year to bypass that issue. Over the last week or so I’ve noticed stability issues with the latest version of HG. I investigated further and have tracked down the offending dependencies. I’ve modified my own installation to reflect this. I’m not sure if other image maintainers have done this too.

If you do indeed want to install HG 1.3 v5 on your Raspberry Pi send me a PM and I will go through the changes I made. In the meantime here are the original installation instructions Installing HG on Raspbian Buster using gdebi