Python Script Assistance - Meross Sensons

Should you be trying to establish an https connection to Meross. Have you tried http instead.

A nice little write up for Meross in Domoticz that might be of use. I’ve Domoticz installed and it’s quite useful.

I just tried http instead of https - I don’t get anything back with that. With https I am at least getting the string returned I mentioned.

I may reach out to the person who developed the Python library and see if they could share the API documentation from Meross. In the meantime, I will check out the link you provided.

I read thru the info on the link (Domoticz) and it seems to be the same approach I am attempting. At least in HG, the issue appears to be trying to get the script to compile and run with the import commands finding the modules it needs without error - there appear to be dependencies in the meross modules to other modules that are not being loaded (i.e. the base64 error). I’m stuck trying to resolve that.

Interestingly, in the Domocticz post from the link you provided it is mentioned that IFTTT is also an option - and that is what I had been working on the other day. I have a dummy switch set up in HG and then defined an IFTTT applet to send an On or Off command (based on the humidity) to HG and that does seem to work.

If that proves reliable, I may just use that but the python script offered much more info and control (i.e. you can get the actual temp and humidity readings wheras the IFTTT applet just sends a message when the trigger is reached, and does not include the actual temp or humidity value).

Yes Alberto would be the man to contact on all things Meross and Python. Possibly the best route to go at this stage

I posted this on the github site for the Meross IOT library:

Perfect and the Github is active as can be seen from the latest update. I’ll give you one thing, you’re persistent and hopefully a solution will pay off as a result.

I got a reply from the Python script developer:
“The current version of the library 0.4.X.X requires Python 3.7+. I guess your version of HomeGenie is running the script with a lower version of Python. If that’s the case, the only way you have to run this library is to upgrade the Python version to 3.7 or 3.8.”

Which confirms what I thought - HG itself needs to be updated to allow use of the newest Python version.

I entered a new feature request on the HG GitHub site:

I commented in the GitHub on this.

HG deploys Iron Python and it does indeed use the latest version 2.7 so nothing can be done there on versioning.

You might want to read up on the differences between Iron Python and Python to get to the bottom of this. Iron Python is generally deployed in the .Net environment which would explain a lot here.