JkUtils - Solar Altitude = getting error in Widget since 1.3-stable.9 update

Good morning

I had noticed this the other day and tried looking into it, and I took the 1.3-stable.10 update this morning thinking maybe it would resolve the problem but its still there.

The Jk-Utils Solar Altitude program runs with no errors but the Widget has the following error:

TypeError: this.DataUiFieldsDisplayed[i].substr is not a function

This is in the ConvertTime function

Not sure what may have changed but I am running the standard version of this utility. Does anyone else have the same error with the widget?

Might be best to post that as an issue on Genes GitHub as it relates directly to an update provided by Gene.

Good point, I added a new issue on GitHub

With the assistance of mralapete on the github site for HG (see the link to the reported issue in my post from June 8th), the issue had been tracked down (it has to do with the Preferences being loaded when the Parameters already are) - commenting out some code in the widget Javascript and HTML will resolve the issue. Details are in the GitHum post but for reference will mention here too:
Comment out the following lines in the JK Utils Solar Altitiude Widget resolved the issue for me:
Javascript = lines 81 thru 136
HTML = lines 411 thru 443


Getting the time to look through the logic of the widget/program combination I could see the duplication defining the parameters between the widget and the program.

As I mentioned in the GitHub the program Options was something that was introduced post JK Utils Solar Altitude and OpenWeather so the widget was handling parameter definition via a Preferences pop up. The pop up was preventing the predefined parameters from the Options section in the program being passed to the widget. Disabling that pop up has clearly resolved the issue now.

It was worth your while @soxfan1966 spending the time with this now that the issue has been resolved. Helped with the learning process too. :joy: