Amazon Alexa


#161

Tuicemen thanks for your advice.
I think you’re right too.

I try to avoid updates, if not necessary, only because of the bad experiences I had in the past, which forced me to spend a lot of time reconfiguring the whole system.
In fact, I really hope that some users have managed to solve a similar problem with HGEB, so I do not have to do the update right now.:slightly_smiling_face:

Roberto


#162

@roberto1979 I know I covered the username and password issue in an earlier post but just make sure when doing a fresh install that you don’t set either. It’s vital those two fields are blank on HG otherwise the HGEB will not be able to establish a connection to HG and the discovery service will not run.

The less services you have running in HG when attempting to setup the HGEB service the better. Of course make sure UPnP is disabled BEFORE you attempt to install HGEB.


#163

In fact, in my opinion you are right. Please, is not there any way to disable the user name “Admin”?

Thanks, of course, I deactivated every service during my previous tests. Among other things, I do not use UPNP, so this is always disabled …


#164

Hmm… What version of Mono do you have, @roberto1979? Type mono --version in terminal.


#165

@Bounz from the post above @roberto1979 is running Raspbian Wheezy with Mono 3.2 (not ideal). That’s why I suggested using Stretch with the repo Mono 4.6 to see if this solved his issue.


#166

Hi Bounz,
I have this version of mono:

RPI 2:
HG 1.1betaR526
Raspbian Id=7 Wheezy
Mono Version 3.2.8 (Debian 3.2.8+dfsg-4+rpi1)
Could it be possible to use a more up-to-date version of Mono with Raspbian 7?

RPI3:
HG 1.1StableR527
Raspbian Id=9 Stretch
Mono Version 4.6.2 (Debian 4.6.2.7 +dfsg-1)


#167

Wasn’t aware you had two different versions of Raspbian you were trying your install on.

You can forget the Wheezy install. Looks like you have security certs issues there. As far as I’m aware Wheezy security support ended in 2018

Just concentrate on your RPI3 Stretch install and use the pointers I gave you earlier.


#168

@Petediscrete, please, what do you mean by security issues?


#169

Security certificate issues. Just read this to give you an idea of what I’m talking about. https://serverfault.com/questions/891734/debian-wheezy-outdated-root-certificates

My advice is retire Wheezy and use Stretch to avoid these issues.


#170

Thanks, I’ll go into the subject right away.


#171

…With all these tests my HG is gone…
Please, does anyone know what could be the reason for this error and how to solve it?
I also tried to do a new installation of HG but this did not solve the problem.

[email protected] ~ $ sudo /etc/init.d/homegenie stop
start-stop-daemon: warning: failed to kill 2498: No such process
No process in pidfile ‘/tmp/homegenie.pid’ found running; none killed.
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec … or kill -l [sigspec]
[ ok ] homegenie stopped.


#172

Roberto could you please indicate what version of Raspbian you are using here to do this troubleshooting now.


#173

It’s sudo systemctl homegenie.service stop to stop the homegenie service or start to start the service in Raspbian Stretch.

Are you still trying this with Raspbian Wheezy ???


#174

@Petediscrete NO, I’m not still trying to make HGEB work with RPI2 and Wheezy.

Concerning HGEB, I made a new installation on RPI3 with the latest version of Gene, following the advice of someone who wrote in some post above that with that version had not encountered any problem with HGEB.
Even with this version, HGEB does not seem to work in my network, but Echo input has recognized devices with UPnP Emulator. (which also seems to have problems because at each shutdown, the previously associated devices are not found, and doing a new search, the new devices are in conflict with the previous ones because they obviously have the same name).

Now, my problem is not with HGEB, which for the moment I have abandoned due to lack of time to devote, but with RPI2, on which are installed some important programs that currently I can not interrupt.
As a result of the tests I did, HG no longer works on RPI2, and if I restore a previous backup, i will lose other data from the other program running on RPI2 too.

Please, can you tell me if the error of which I wrote 2 messages above is unsolvable?


#175

@roberto1979 as I mentioned earlier Raspbian Wheezy is no longer supported. Keep all you testing with Raspbian Stretch. If you have a HG backup you should have no problem restoring it to your Raspbian Stretch install.

Yes I have experienced a delay with HG recognising my devices with a reboot. Just give it a little time for the Discovery service to do it’s job.

As you stated you have a Raspberry Pi 3 so go to Alexa, forget all the devices and run a new discovery. This is best achieved on a PC.


#176

Did you take an image copy of your Raspbian Wheezy version of HG before you started installing HGEB on top of it. If so just write that image back to a freshly formatted SD card.

Have you tried restoring the backup of your HG configuration you made of the Pi2 to the Pi3 after you freshly installed Raspbian Stretch and HG. What were the results.


#177

It might be an idea to make a new post on this issue you have now.


#178

Hi @Petediscrete.
I promised myself that I would not have done it, but I could not resist the temptation, so I’m updating the RPI2 to Stretch. Although I know this will involve a lot of work to restore everything. (Not just about HG)
I’ll update you as soon as I complete the installation and try to restore HG Backup. (If everything goes as it did in the past, I already know that I will have to reconfigure everything).:sob::sob::sob:
Roberto


#179

This message indicate that homegenie process did not run anymore when you try to kill it.
It is already stopped.


#180

Exactly. When I was relaunching the HG service, everything seemed to be regular but homegenie did not work. After the revival, trying to stop the service, I received that message.
I had also tried with a new installation of HG, but the service did not restart (More precisely, it seemed to be apparently executed, because I received no error message, but by querying the Status, the service was not running).